Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM's Software TPM 2.0" |
| 2 | DESCRIPTION = "The software TPM 2.0 is targeted toward application development, \ |
| 3 | education, and virtualization. \ |
| 4 | \ |
| 5 | The intent is that an application can be developed using the software TPM. \ |
| 6 | The application should then run using a hardware TPM without changes. \ |
| 7 | Advantages of this approach: \ |
| 8 | * In contrast to a hardware TPM, it runs on many platforms and it's generally faster. \ |
| 9 | * Application software errors are easily reversed by simply removing the TPM state and starting over. \ |
| 10 | * Difficult crypto errors are quickly debugged by looking inside the TPM." |
| 11 | HOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmswtpm2.html" |
| 12 | LICENSE = "BSD" |
| 13 | SECTION = "securty/tpm" |
| 14 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f" |
| 15 | |
| 16 | DEPENDS = "openssl" |
| 17 | |
| 18 | SRC_URI = "https://sourceforge.net/projects/ibmswtpm2/files/ibmtpm${PV}.tar.gz \ |
| 19 | file://tune-makefile.patch \ |
| 20 | file://fix-wrong-cast.patch \ |
| 21 | " |
| 22 | SRC_URI[md5sum] = "43b217d87056e9155633925eb6ef749c" |
| 23 | SRC_URI[sha256sum] = "dd3a4c3f7724243bc9ebcd5c39bbf87b82c696d1c1241cb8e5883534f6e2e327" |
| 24 | SRC_URI[sha1sum] = "ab4b94079e57a86996991e8a2b749ce063e4ad3e" |
| 25 | SRC_URI[sha384sum] = "bbef16a934853ce78cba7ddc766aa9d7ef3cde3430a322b1be772bf3ad4bd6d413ae9c4de21bc1a4879d17dfe2aadc1d" |
| 26 | SRC_URI[sha512sum] = "007aa415cccf19a2bcf789c426727dc4032dcb04cc9d11eedc231d2add708c1134d3d5ee5cfbe7de68307c95fff7a30bd306fbd8d53c198a5ef348440440a6ed" |
| 27 | |
| 28 | S = "${WORKDIR}/src" |
| 29 | |
| 30 | CFLAGS += "-Wno-error=maybe-uninitialized" |
| 31 | |
| 32 | do_compile () { |
| 33 | make CC='${CC}' |
| 34 | } |
| 35 | |
| 36 | do_install () { |
| 37 | install -d ${D}/${bindir} |
| 38 | install -m 0755 tpm_server ${D}/${bindir} |
| 39 | } |