Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Matchbox Window Manager Desktop" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "A lightweight windows manager for embedded systems. It uses the desktop background to provide an application launcher and allows modules to be loaded for additional functionality." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 3 | HOMEPAGE = "http://matchbox-project.org/" |
| 4 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 5 | |
| 6 | LICENSE = "GPLv2+ & LGPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://src/desktop.c;endline=20;md5=36c9bf295e6007f3423095f405af5a2d \ |
| 9 | file://src/main.c;endline=19;md5=2044244f97a195c25b7dc602ac7e9a00" |
| 10 | |
| 11 | DEPENDS = "gtk+3 startup-notification dbus" |
| 12 | SECTION = "x11/wm" |
| 13 | |
| 14 | # SRCREV tagged 2.2 |
| 15 | SRCREV = "6bc67d09da4147e5552fe30011a05a2c59d2f777" |
| 16 | SRC_URI = "git://git.yoctoproject.org/${BPN}-2 \ |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 17 | file://vfolders/ \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | EXTRA_OECONF = "--enable-startup-notification --with-dbus" |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 24 | inherit autotools pkgconfig features_check |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 25 | |
| 26 | # The startup-notification requires x11 in DISTRO_FEATURES |
| 27 | REQUIRED_DISTRO_FEATURES = "x11" |
| 28 | |
| 29 | do_install_append() { |
| 30 | install -d ${D}${datadir}/matchbox/vfolders/ |
| 31 | install -m 0644 ${WORKDIR}/vfolders/* ${D}${datadir}/matchbox/vfolders/ |
| 32 | } |
| 33 | |
| 34 | FILES_${PN} += "${datadir}/matchbox/vfolders/" |