Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | require ruby.inc |
| 2 | |
| 3 | SRC_URI += " \ |
| 4 | file://ruby-CVE-2017-9226.patch \ |
| 5 | file://ruby-CVE-2017-9228.patch \ |
| 6 | " |
| 7 | |
| 8 | SRC_URI[md5sum] = "f4711f856fe14de222b9da3d3b8efa89" |
| 9 | SRC_URI[sha256sum] = "46e6f3630f1888eb653b15fa811d77b5b1df6fd7a3af436b343cfe4f4503f2ab" |
| 10 | |
| 11 | # it's unknown to configure script, but then passed to extconf.rb |
| 12 | # maybe it's not really needed as we're hardcoding the result with |
| 13 | # 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch |
| 14 | UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo" |
| 15 | |
| 16 | PACKAGECONFIG ??= "" |
| 17 | PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 18 | |
| 19 | PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind" |
| 20 | PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp" |
| 21 | PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo," |
| 22 | |
| 23 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 24 | |
| 25 | EXTRA_OECONF = "\ |
| 26 | --disable-versioned-paths \ |
| 27 | --disable-rpath \ |
| 28 | --disable-dtrace \ |
| 29 | --enable-shared \ |
| 30 | --enable-load-relative \ |
| 31 | " |
| 32 | |
| 33 | do_install() { |
| 34 | oe_runmake 'DESTDIR=${D}' install |
| 35 | } |
| 36 | |
| 37 | PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc" |
| 38 | |
| 39 | SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library" |
| 40 | RDEPENDS_${PN}-ri-docs = "${PN}" |
| 41 | FILES_${PN}-ri-docs += "${datadir}/ri" |
| 42 | |
| 43 | SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source" |
| 44 | RDEPENDS_${PN}-rdoc = "${PN}" |
| 45 | FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc" |
| 46 | |
| 47 | FILES_${PN} += "${datadir}/rubygems" |
| 48 | |
| 49 | BBCLASSEXTEND = "native" |