Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "The NTFS-3G driver is an open source, freely available NTFS driver for Linux with read and write support." |
| 2 | HOMEPAGE = "http://www.ntfs-3g.org/" |
| 3 | DEPENDS = "fuse libgcrypt" |
| 4 | PROVIDES = "ntfsprogs ntfs-3g" |
| 5 | LICENSE = "GPLv2 & LGPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ |
| 7 | file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" |
| 8 | |
| 9 | SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz \ |
| 10 | file://0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch \ |
| 11 | " |
| 12 | S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}" |
| 13 | SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c" |
| 14 | SRC_URI[sha256sum] = "3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5" |
| 15 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | UPSTREAM_CHECK_URI = "https://www.tuxera.com/community/open-source-ntfs-3g/" |
| 17 | UPSTREAM_CHECK_REGEX = "ntfs-3g_ntfsprogs-(?P<pver>\d+(\.\d+)+)\.tgz" |
| 18 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | inherit autotools pkgconfig |
| 20 | |
| 21 | PACKAGECONFIG ??= "" |
| 22 | PACKAGECONFIG[uuid] = "--with-uuid,--without-uuid,util-linux" |
| 23 | |
| 24 | # required or it calls ldconfig at install step |
| 25 | EXTRA_OEMAKE = "LDCONFIG=echo" |
| 26 | |
| 27 | PACKAGES =+ "ntfs-3g ntfsprogs libntfs-3g" |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | FILES:ntfs-3g = "${base_sbindir}/*.ntfs-3g ${bindir}/ntfs-3g* ${base_sbindir}/mount.ntfs" |
| 30 | RDEPENDS:ntfs-3g += "fuse" |
| 31 | RRECOMMENDS:ntfs-3g = "util-linux-mount" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | FILES:ntfsprogs = "${base_sbindir}/* ${bindir}/* ${sbindir}/*" |
| 34 | FILES:libntfs-3g = "${libdir}/*${SOLIBS}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 37 | # Standard mount will execute the program /sbin/mount.TYPE when called. |
| 38 | # Add a symbolic link to let mount find ntfs. |
| 39 | ln -sf mount.ntfs-3g ${D}${base_sbindir}/mount.ntfs |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 40 | rmdir ${D}${libdir}/ntfs-3g |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 41 | |
| 42 | # Handle when usrmerge is in effect. Some files are installed to /sbin |
| 43 | # regardless of the value of ${base_sbindir}. |
| 44 | if [ "${base_sbindir}" != /sbin ] && [ -d ${D}/sbin ]; then |
| 45 | mkdir -p ${D}${base_sbindir} |
| 46 | mv ${D}/sbin/* ${D}${base_sbindir} |
| 47 | rmdir ${D}/sbin |
| 48 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 49 | } |
| 50 | |
| 51 | # Satisfy the -dev runtime dependency |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 52 | ALLOW_EMPTY:${PN} = "1" |