Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 1 | SUMMARY = "GTK+ icon theme" |
| 2 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/adwaita-icon-theme" |
| 3 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/adwaita-icon-theme/issues" |
| 4 | SECTION = "x11/gnome" |
| 5 | |
| 6 | LICENSE = "LGPL-3.0 | CC-BY-SA-3.0" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=c84cac88e46fc07647ea07e6c24eeb7c \ |
| 8 | file://COPYING_CCBYSA3;md5=96143d33de3a79321b1006c4e8ed07e7 \ |
| 9 | file://COPYING_LGPL;md5=e6a600fd5e1d9cbde2d983680233ad02" |
| 10 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 11 | inherit allarch autotools pkgconfig gettext gtk-icon-cache |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 12 | |
| 13 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" |
| 14 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \ |
| 15 | file://0001-Don-t-use-AC_CANONICAL_HOST-3.34.3.patch \ |
| 16 | file://0001-Run-installation-commands-as-shell-jobs.patch \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI[md5sum] = "9aea4ad9bc002aacad155ee0748b357f" |
| 20 | SRC_URI[sha256sum] = "e7c2d8c259125d5f35ec09522b88c8fe7ecf625224ab0811213ef0a95d90b908" |
| 21 | |
| 22 | DEPENDS += "librsvg-native" |
| 23 | |
| 24 | PACKAGES = "${PN}-cursors ${PN}-symbolic-hires ${PN}-symbolic ${PN}-hires ${PN}" |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | RREPLACES:${PN} = "gnome-icon-theme" |
| 27 | RCONFLICTS:${PN} = "gnome-icon-theme" |
| 28 | RPROVIDES:${PN} = "gnome-icon-theme" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | FILES:${PN}-cursors = "${prefix}/share/icons/Adwaita/cursors/" |
| 31 | FILES:${PN}-symbolic-hires = "${prefix}/share/icons/Adwaita/96x96/*/*.symbolic.png \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 32 | ${prefix}/share/icons/Adwaita/64x64/*/*.symbolic.png \ |
| 33 | ${prefix}/share/icons/Adwaita/48x48/*/*.symbolic.png \ |
| 34 | ${prefix}/share/icons/Adwaita/32x32/*/*.symbolic.png" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | FILES:${PN}-symbolic = "${prefix}/share/icons/Adwaita/16x16/*/*.symbolic.png \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 36 | ${prefix}/share/icons/Adwaita/24x24/*/*.symbolic.png \ |
| 37 | ${prefix}/share/icons/Adwaita/scalable/*/*-symbolic*.svg" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN}-hires = "${prefix}/share/icons/Adwaita/256x256/ \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 39 | ${prefix}/share/icons/Adwaita/512x512/" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | FILES:${PN} = "${prefix}/share/icons/Adwaita/ \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 41 | ${prefix}/share/pkgconfig/adwaita-icon-theme.pc" |
| 42 | |
| 43 | BBCLASSEXTEND = "native nativesdk" |