Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "An Open Source implementation of the iCalendar protocols \ |
| 3 | and protocol data units. The iCalendar specification describes how \ |
| 4 | calendar clients can communicate with calendar servers so users can store \ |
| 5 | their calendar data and arrange meetings with other users. " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | HOMEPAGE = "https://github.com/libical/libical" |
| 7 | BUGTRACKER = "https://github.com/libical/libical/issues" |
| 8 | LICENSE = "LGPLv2.1 | MPL-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \ |
| 10 | file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \ |
| 11 | file://LICENSE.MPL2.txt;md5=f75d2927d3c1ed2414ef72048f5ad640 \ |
| 12 | " |
| 13 | SECTION = "libs" |
| 14 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 15 | SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | " |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "f933b3e6cf9d56a35bb5625e8e4a9c3a50239a85aea05ed842932c1a1dc336b4" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases" |
| 19 | |
| 20 | inherit cmake pkgconfig |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | DEPENDS:append:class-target = "libical-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | |
| 24 | PACKAGECONFIG ??= "icu glib" |
| 25 | PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db" |
| 26 | PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2" |
| 27 | # ICU is used for RSCALE (RFC7529) support |
| 28 | PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu" |
| 29 | |
| 30 | # No need to use perl-native, the host perl is sufficient. |
| 31 | EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl" |
| 32 | # doc build fails with linker error (??) for libical-glib so disable it |
| 33 | EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false" |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | EXTRA_OECMAKE:append:class-target = " -DIMPORT_ICAL_GLIB_SRC_GENERATOR=${STAGING_LIBDIR_NATIVE}/cmake/LibIcal/IcalGlibSrcGenerator.cmake" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | do_install:append () { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 38 | # Remove build host references |
| 39 | sed -i \ |
| 40 | -e 's,${STAGING_LIBDIR},${libdir},g' \ |
| 41 | -e 's,${STAGING_INCDIR},${includedir},g' \ |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 42 | ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake \ |
| 43 | ${D}${libdir}/cmake/LibIcal/Ical*.cmake |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | } |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 45 | |
| 46 | BBCLASSEXTEND = "native" |