Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # mtools OE build file |
| 2 | # Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved |
| 3 | # Released under the MIT license (see packages/COPYING) |
| 4 | |
| 5 | SUMMARY = "Utilities to access MS-DOS disks without mounting them" |
| 6 | DESCRIPTION = "Mtools is a collection of utilities for accessing MS-DOS disks from Unix without mounting them." |
| 7 | HOMEPAGE = "http://www.gnu.org/software/mtools/" |
| 8 | LICENSE = "GPLv2+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=92b58ec77696788ce278b044d2a8e9d3" |
| 10 | PR = "r6" |
| 11 | |
| 12 | RDEPENDS_${PN} = "glibc-gconv-ibm850" |
| 13 | RRECOMMENDS_${PN} = "\ |
| 14 | glibc-gconv-ibm437 \ |
| 15 | glibc-gconv-ibm737 \ |
| 16 | glibc-gconv-ibm775 \ |
| 17 | glibc-gconv-ibm851 \ |
| 18 | glibc-gconv-ibm852 \ |
| 19 | glibc-gconv-ibm855 \ |
| 20 | glibc-gconv-ibm857 \ |
| 21 | glibc-gconv-ibm860 \ |
| 22 | glibc-gconv-ibm861 \ |
| 23 | glibc-gconv-ibm862 \ |
| 24 | glibc-gconv-ibm863 \ |
| 25 | glibc-gconv-ibm865 \ |
| 26 | glibc-gconv-ibm866 \ |
| 27 | glibc-gconv-ibm869 \ |
| 28 | " |
| 29 | |
| 30 | #http://mtools.linux.lu/mtools-${PV}.tar.gz |
| 31 | SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/mtools-${PV}.tar.gz \ |
| 32 | file://mtools-makeinfo.patch \ |
| 33 | file://mtools.patch \ |
| 34 | file://no-x11.patch \ |
| 35 | file://fix-broken-lz.patch \ |
| 36 | " |
| 37 | |
| 38 | SRC_URI[md5sum] = "3e68b857b4e1f3a6521d1dfefbd30a36" |
| 39 | SRC_URI[sha256sum] = "af083a73425d664d4607ef6c6564fd9319a0e47ee7c105259a45356cb834690e" |
| 40 | |
| 41 | S = "${WORKDIR}/mtools-${PV}" |
| 42 | |
| 43 | inherit autotools texinfo |
| 44 | |
| 45 | EXTRA_OECONF = "--without-x" |
| 46 | |
| 47 | BBCLASSEXTEND = "native nativesdk" |
| 48 | |
| 49 | PACKAGECONFIG ??= "" |
| 50 | PACKAGECONFIG[libbsd] = "ac_cv_lib_bsd_main=yes,ac_cv_lib_bsd_main=no,libbsd" |
| 51 | |
| 52 | do_install_prepend () { |
| 53 | # Create bindir to fix parallel installation issues |
| 54 | mkdir -p ${D}/${bindir} |
| 55 | mkdir -p ${D}/${datadir} |
| 56 | } |