Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "library for easy implementation of a RDP/VNC server" |
| 2 | HOMEPAGE = "https://libvnc.github.io" |
| 3 | SECTION = "libs" |
| 4 | PRIORITY = "optional" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f" |
| 7 | |
| 8 | DEPENDS += "zlib libsdl jpeg libpng gtk+ libgcrypt nettle gnutls gmp" |
| 9 | |
| 10 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}" |
| 11 | PACKAGECONFIG[systemd] = ",,systemd" |
| 12 | |
| 13 | RDEPENDS_${PN} += "libpng gtk+ libgcrypt" |
| 14 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | inherit distro_features_check autotools binconfig pkgconfig |
| 16 | |
| 17 | REQUIRED_DISTRO_FEATURES = "x11" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | |
| 19 | SRC_URI = "https://github.com/LibVNC/libvncserver/archive/LibVNCServer-${PV}.tar.gz" |
| 20 | SRC_URI[md5sum] = "7f06104d5c009813e95142932c4ddb06" |
| 21 | SRC_URI[sha256sum] = "193d630372722a532136fd25c5326b2ca1a636cbb8bf9bb115ef869c804d2894" |
| 22 | |
| 23 | S = "${WORKDIR}/${BPN}-LibVNCServer-${PV}" |
| 24 | |
| 25 | TARGET_LDFLAGS += "-lgcrypt" |