blob: 29917c8a1463679c6be2ed5744f20c2d689fada7 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "Ceres Solver is an open source C++ library for modeling and solving large, complicated optimization problems."
2AUTHOR = "Sameer Agarwal and Keir Mierle and Others"
3HOMEPAGE = "http://ceres-solver.org/"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=35e00f0c4c96a0820a03e0b31e6416be"
7
8SRC_URI = "git://github.com/ceres-solver/ceres-solver.git"
9SRCREV = "facb199f3eda902360f9e1d5271372b7e54febe1"
10
11S = "${WORKDIR}/git"
12
13DEPENDS = "libeigen glog"
14
15inherit cmake
16
17# Only a static library and headers are created
18ALLOW_EMPTY_${PN} = "1"
19
20FILES_${PN}-dev += "${libdir}/cmake/*"