Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Provides a way to load and enumerate PKCS#11 modules" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = " Provides a standard configuration setup for installing PKCS#11 modules in such a way that they're discoverable. Also solves problems with coordinating the use of PKCS#11 by different components or libraries living in the same process." |
| 3 | HOMEPAGE = "https://p11-glue.github.io/p11-glue/p11-kit.html" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50" |
| 6 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 7 | inherit meson gettext pkgconfig gtk-doc bash-completion manpages |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | |
| 9 | DEPENDS = "libtasn1 libtasn1-native libffi" |
| 10 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 11 | DEPENDS:append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 13 | SRC_URI = "git://github.com/p11-glue/p11-kit" |
| 14 | SRCREV = "34826623f58399b24c21f1788e2cdaea34521b7b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 18 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates" |
| 20 | |
| 21 | GTKDOC_MESON_OPTION = 'gtk_doc' |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | FILES:${PN} += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | ${libdir}/p11-kit-proxy.so \ |
| 25 | ${libdir}/pkcs11/*.so \ |
| 26 | ${libdir}/pkcs11/*.la \ |
| 27 | ${systemd_user_unitdir}/*" |
| 28 | |
| 29 | # PN contains p11-kit-proxy.so, a symlink to a loadable module |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | INSANE_SKIP:${PN} = "dev-so" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | |
| 32 | BBCLASSEXTEND = "nativesdk" |