blob: 642cec1598cbdf2e04eecfa1b1445ac0112ae87c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips"
2LICENSE = "GPLv2"
3HOMEPAGE = "http://flashrom.org"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6DEPENDS = "pciutils libusb libusb-compat"
7
8SRC_URI = "https://download.flashrom.org/releases/flashrom-v${PV}.tar.bz2 \
9 file://0001-typecast-enum-conversions-explicitly.patch \
10 "
11SRC_URI[md5sum] = "7f8e4b87087eb12ecee0fcc5445b4956"
12SRC_URI[sha256sum] = "e1f8d95881f5a4365dfe58776ce821dfcee0f138f75d0f44f8a3cd032d9ea42b"
13
14S = "${WORKDIR}/flashrom-v${PV}"
15
16inherit pkgconfig
17
18do_install() {
19 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
20}