blob: a1378866ad478d4dec1de223ddb8fe105dc17f09 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Timing analysis tools for suspend/resume/boot"
2DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \
3in optimizing their linux stack's suspend/resume & boot time."
4HOMEPAGE = "https://01.org/pm-graph"
5LICENSE = "GPL-2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
7
Brad Bishopa891d152019-09-13 06:17:45 -04008SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
Brad Bishopc8f47122019-06-24 09:36:18 -04009SRC_URI = "git://github.com/intel/pm-graph.git \
Brad Bishop26bdd442019-08-16 17:08:17 -040010 file://0001-Makefile-fix-multilib-build-failure.patch \
Brad Bishopa891d152019-09-13 06:17:45 -040011 file://0001-sleepgraph.py-use-python3.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040012"
Brad Bishop15ae2502019-06-18 21:44:24 -040013S = "${WORKDIR}/git"
14
Andrew Geissler82c905d2020-04-13 13:39:40 -050015# Apart from the listed RDEPENDS, analyze-suspend depends on some features
16# provided by the kernel. These options are:
17# - CONFIG_PM_DEBUG=y
18# - CONFIG_PM_SLEEP_DEBUG=y
19# - CONFIG_FTRACE=y
20# - CONFIG_FUNCTION_TRACER=y
21# - CONFIG_FUNCTION_GRAPH_TRACER=y
22
Brad Bishop15ae2502019-06-18 21:44:24 -040023COMPATIBLE_HOST='(i.86|x86_64).*'
Brad Bishopc8f47122019-06-24 09:36:18 -040024EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
Brad Bishop15ae2502019-06-18 21:44:24 -040025
26do_install() {
27 oe_runmake install
Andrew Geissler82c905d2020-04-13 13:39:40 -050028 install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py
Brad Bishop15ae2502019-06-18 21:44:24 -040029}
30
Brad Bishopa891d152019-09-13 06:17:45 -040031RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression"
Andrew Geissler82c905d2020-04-13 13:39:40 -050032RPROVIDES_${PN} = "analyze-suspend"
33BBCLASSEXTEND = "native nativesdk"