Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags" |
| 2 | DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \ |
| 3 | compiler that is compatible with the C compiler that your perl was built \ |
| 4 | with. \ |
| 5 | It can generate the necessary options to the Module::Build constructor or \ |
| 6 | to ExtUtils::MakeMaker's WriteMakefile function." |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/" |
| 10 | |
| 11 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 12 | LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699" |
| 13 | |
| 14 | SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz" |
| 15 | SRC_URI[md5sum] = "62bdf731bcbe988d07486836e11585f7" |
| 16 | SRC_URI[sha256sum] = "ff629178321a1e591b83f809712593eae4408a413aa448654bce59b156f24153" |
| 17 | |
| 18 | S = "${WORKDIR}/ExtUtils-CppGuess-${PV}" |
| 19 | |
| 20 | inherit cpan |
| 21 | |
| 22 | do_install () { |
| 23 | cpan_do_install |
| 24 | } |
| 25 | |
| 26 | RDEPENDS_${PN} = " libcapture-tiny-perl \ |
| 27 | perl-module-scalar-util \ |
| 28 | perl-module-io-file \ |
| 29 | perl-module-extutils-makemaker \ |
| 30 | perl-module-file-spec \ |
| 31 | perl-module-exporter \ |
| 32 | perl-module-carp \ |
| 33 | perl-module-file-temp \ |
| 34 | perl-module-lib \ |
| 35 | " |
| 36 | |
| 37 | BBCLASSEXTEND = "native" |