Brad Bishop | 74c51e9 | 2018-11-05 20:47:38 -0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
Brad Bishop | 07d2b9d | 2019-09-13 13:04:22 -0400 | [diff] [blame] | 2 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Brad Bishop | 74c51e9 | 2018-11-05 20:47:38 -0800 | [diff] [blame] | 3 | |
Patrick Venture | 6c90108 | 2018-04-13 13:41:52 -0700 | [diff] [blame] | 4 | inherit native |
Patrick Venture | 6c90108 | 2018-04-13 13:41:52 -0700 | [diff] [blame] | 5 | |
| 6 | DEPENDS += "virtual/phosphor-ipmi-fru-inventory" |
| 7 | PROVIDES += "virtual/phosphor-ipmi-fru-merge-config" |
| 8 | |
| 9 | # Put the fru_config in the right place with the right name. |
| 10 | # Pull the IPMI FRU YAML config to use it in the IPMI HOST YAML. |
David Wang | 026925d | 2021-08-13 11:39:20 +0800 | [diff] [blame] | 11 | do_install:append() { |
Patrick Venture | 6c90108 | 2018-04-13 13:41:52 -0700 | [diff] [blame] | 12 | IPMI_FRU_SRC=${datadir}/phosphor-ipmi-fru/config |
| 13 | IPMI_HOST_DEST=${D}${datadir}/phosphor-ipmi-host/config |
| 14 | install -d ${IPMI_HOST_DEST} |
| 15 | cat ${IPMI_FRU_SRC}/config.yaml > ${IPMI_HOST_DEST}/fru_config.yaml |
| 16 | } |