Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl script that converts Texinfo to HTML" |
| 2 | HOMEPAGE = "http://www.nongnu.org/texi2html/" |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 6 | |
| 7 | PR = "r2" |
| 8 | |
| 9 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/texi2html/${BPN}-${PV}.tar.bz2 \ |
Brad Bishop | 37a0e4d | 2017-12-04 01:01:44 -0500 | [diff] [blame] | 10 | file://0001-Allow-compiling-out-of-source.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | " |
| 12 | |
| 13 | SRC_URI[md5sum] = "f15ac876fcdc8be865b16535f480aa54" |
| 14 | SRC_URI[sha256sum] = "e8a98b0ee20c495a6ab894398a065ef580272dbd5a15b1b19e8bd1bc89d9f9fa" |
| 15 | |
| 16 | inherit autotools gettext texinfo |
| 17 | |
| 18 | do_configure_prepend() { |
| 19 | # autotools_do_configure updates po/Makefile.in.in, we also need |
| 20 | # update po_document. |
| 21 | cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po_document/ |
| 22 | cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po_messages/ |
| 23 | } |
| 24 | |
| 25 | do_install_append () { |
| 26 | sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/texi2html |
| 27 | } |
| 28 | |
| 29 | FILES_${PN}-doc += "${datadir}/texinfo" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 30 | |
| 31 | RDEPENDS_${PN} = "perl" |