Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome/libs" |
| 5 | LICENSE = "LGPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 7 | |
| 8 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native" |
| 9 | |
| 10 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 11 | |
| 12 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "4cf8937d161d3dd71a65f1684e317824" |
| 15 | SRC_URI[sha256sum] = "1b0dc762f23abe4e0d29b77370e539fd35f31d8e8e0318d6ddccff395be68a22" |
| 16 | |
| 17 | S = "${WORKDIR}/libsoup-${PV}" |
| 18 | |
| 19 | inherit autotools gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 20 | |
| 21 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome" |
| 24 | PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5" |
| 25 | |
| 26 | EXTRA_OECONF = "--disable-vala" |
| 27 | |
| 28 | # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| 29 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 30 | # renaming in order to keep the package name consistent regardless of whether |
| 31 | # gnome support is enabled or disabled. |
| 32 | DEBIAN_NOAUTONAME_${PN} = "1" |
| 33 | |
| 34 | # glib-networking is needed for SSL, proxies, etc. |
| 35 | RRECOMMENDS_${PN} = "glib-networking" |