blob: 3f5a30ec6c2f944f45ae86a48722d7af96d2963d [file] [log] [blame]
Lancelot Kao4357d532021-02-22 15:20:35 -06001SUMMARY = "Phosphor OpenBMC Kudo Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC Kudo Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
13RDEPENDS_${PN} += "libsystemd"
14RDEPENDS_${PN} += "bash"
15
16
17SRC_URI_append_kudo = " \
18 file://kudo-fw.sh \
19 file://kudo-fw-ver.service \
20 file://kudo-fw-ver.sh \
21 "
22
23SYSTEMD_PACKAGES = "${PN}"
24SYSTEMD_SERVICE_${PN}_append_kudo = " \
25 kudo-fw-ver.service \
26 "
27
28do_install () {
29 install -d ${D}/${sbindir}
30 install -m 0755 ${WORKDIR}/kudo-fw.sh ${D}/${sbindir}/kudo-fw.sh
31 install -m 0755 ${WORKDIR}/kudo-fw-ver.sh ${D}/${sbindir}/kudo-fw-ver.sh
32 install -d ${D}${systemd_system_unitdir}
33 install -m 0644 ${WORKDIR}/kudo-fw-ver.service ${D}${systemd_system_unitdir}
34}