Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 1 | OBMC_IMAGE_EXTRA_INSTALL:append:ibm-ac-server = " mboxd max31785-msl phosphor-msl-verify liberation-fonts uart-render-controller first-boot-set-hostname" |
| 2 | OBMC_IMAGE_EXTRA_INSTALL:append:p10bmc = " mboxd ibmtpm2tss" |
| 3 | OBMC_IMAGE_EXTRA_INSTALL:append:witherspoon-tacoma = " ibmtpm2tss" |
| 4 | OBMC_IMAGE_EXTRA_INSTALL:append:mihawk = " mboxd liberation-fonts uart-render-controller " |
Andrew Geissler | d1b5b20 | 2021-01-04 12:16:39 -0600 | [diff] [blame] | 5 | |
| 6 | # remove so things fit in available flash space |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 7 | IMAGE_FEATURES:remove:witherspoon = "obmc-user-mgmt-ldap" |
Andrew Geissler | 3475f83 | 2021-08-12 09:09:41 -0400 | [diff] [blame] | 8 | IMAGE_FEATURES:remove:witherspoon = "obmc-telemetry" |
Joseph Reynolds | 68e567f | 2021-02-24 17:20:01 -0600 | [diff] [blame] | 9 | |
| 10 | # Optionally configure IBM service accounts |
| 11 | # |
| 12 | # To configure your distro, add the following line to its config: |
| 13 | # DISTRO_FEATURES += "ibm-service-account-policy" |
| 14 | # |
| 15 | # The service account policy is as follows: |
| 16 | # root - The root account remains present. It is needed for internal |
| 17 | # accounting purposes and for debugging service access. |
| 18 | # admin - Provides administrative control over the BMC. The role is |
| 19 | # SystemAdministrator. Admin users have access to interfaces including: |
| 20 | # Redfish, REST APIs, Web. No access to the BMC via: the BMC's physical |
| 21 | # console, SSH to the BMC's command line. |
| 22 | # IPMI access is not granted by default, but admins can authorize |
| 23 | # themselves and enable the IPMI service. |
| 24 | # The admin has access to the host console: ssh -p2200 admin@${bmc}. |
| 25 | # The admin account does not have a home directory. |
| 26 | # service - Provides IBM service and support representatives (SSRs, formerly |
| 27 | # known as customer engineers or CEs) access to the BMC. The role is |
| 28 | # OemIBMServiceAgent. The service user has full admin access, plus access |
| 29 | # to BMC interfaces intended only to service the BMC and host, including |
| 30 | # SSH access to the BMC's command line. |
| 31 | # The service account is not authorized to IPMI because of the inherent |
| 32 | # security weakness in the IPMI spec and also because the IPMI |
| 33 | # implementation was not enhanced to use the ACF support. |
| 34 | # The service account does not have a home directory. The home directory is |
| 35 | # set to / (the root directory) to allow dropbear ssh connections. |
| 36 | |
Joseph Reynolds | 516363e | 2021-08-04 10:01:42 -0500 | [diff] [blame] | 37 | # Override defaults from meta-phosphor/conf/distro/include/phosphor-defaults.inc |
Joseph Reynolds | 68e567f | 2021-02-24 17:20:01 -0600 | [diff] [blame] | 38 | inherit extrausers |
| 39 | |
Joseph Reynolds | 68e567f | 2021-02-24 17:20:01 -0600 | [diff] [blame] | 40 | #IBM_EXTRA_USERS_PARAMS += " \ |
Joseph Reynolds | 356f9e1 | 2021-07-23 20:15:32 -0500 | [diff] [blame] | 41 | # usermod -p ${DEFAULT_OPENBMC_PASSWORD} root; \ |
Joseph Reynolds | 68e567f | 2021-02-24 17:20:01 -0600 | [diff] [blame] | 42 | # " |
| 43 | |
| 44 | # Add group "wheel" (before adding the "service" account). |
| 45 | IBM_EXTRA_USERS_PARAMS += " \ |
| 46 | groupadd wheel; \ |
| 47 | " |
| 48 | |
| 49 | # Add the "admin" account. |
| 50 | IBM_EXTRA_USERS_PARAMS += " \ |
| 51 | useradd -M -d / --groups priv-admin,redfish,web -s /sbin/nologin admin; \ |
Joseph Reynolds | 356f9e1 | 2021-07-23 20:15:32 -0500 | [diff] [blame] | 52 | usermod -p ${DEFAULT_OPENBMC_PASSWORD} admin; \ |
Joseph Reynolds | 68e567f | 2021-02-24 17:20:01 -0600 | [diff] [blame] | 53 | " |
| 54 | |
| 55 | # Add the "service" account. |
| 56 | IBM_EXTRA_USERS_PARAMS += " \ |
| 57 | useradd -M -d / --groups priv-admin,redfish,web,wheel service; \ |
Joseph Reynolds | 356f9e1 | 2021-07-23 20:15:32 -0500 | [diff] [blame] | 58 | usermod -p ${DEFAULT_OPENBMC_PASSWORD} service; \ |
Joseph Reynolds | 68e567f | 2021-02-24 17:20:01 -0600 | [diff] [blame] | 59 | " |
| 60 | |
| 61 | # This is recipe specific to ensure it takes effect. |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 62 | EXTRA_USERS_PARAMS:pn-obmc-phosphor-image += "${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', "${IBM_EXTRA_USERS_PARAMS}", '', d)}" |
Joseph Reynolds | 68e567f | 2021-02-24 17:20:01 -0600 | [diff] [blame] | 63 | |
| 64 | # The service account needs sudo. |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 65 | IMAGE_INSTALL:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', 'sudo', '', d)}" |