Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GRUB is the GRand Unified Bootloader" |
| 2 | DESCRIPTION = "GRUB is a GPLed bootloader intended to unify bootloading across x86 \ |
| 3 | operating systems. In addition to loading the Linux kernel, it implements the Multiboot \ |
| 4 | standard, which allows for flexible loading of multiple boot images." |
| 5 | HOMEPAGE = "http://www.gnu.org/software/grub/" |
| 6 | SECTION = "bootloaders" |
| 7 | |
| 8 | LICENSE = "GPLv2+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b \ |
| 10 | file://grub/main.c;beginline=3;endline=9;md5=22a5f28d2130fff9f2a17ed54be90ed6" |
| 11 | |
| 12 | RDEPENDS_${PN} = "diffutils" |
| 13 | PR = "r6" |
| 14 | |
| 15 | SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz; \ |
| 16 | file://no-reorder-functions.patch \ |
| 17 | file://autohell.patch \ |
| 18 | file://grub_fix_for_automake-1.12.patch \ |
| 19 | file://objcopy-absolute.patch \ |
| 20 | file://grub-support-256byte-inode.patch \ |
| 21 | " |
| 22 | |
| 23 | SRC_URI[md5sum] = "cd3f3eb54446be6003156158d51f4884" |
| 24 | SRC_URI[sha256sum] = "4e1d15d12dbd3e9208111d6b806ad5a9857ca8850c47877d36575b904559260b" |
| 25 | |
| 26 | inherit autotools texinfo |
| 27 | |
| 28 | COMPATIBLE_HOST = "i.86.*-linux" |
| 29 | |
| 30 | EXTRA_OECONF = "--without-curses" |
| 31 | |
| 32 | do_install_append_vmware() { |
| 33 | mkdir -p ${D}/boot/ |
| 34 | ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub |
| 35 | } |