Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | include boost-${PV}.inc |
2 | |||||
3 | SUMMARY = "Portable Boost.Jam build tool for boost" | ||||
4 | SECTION = "devel" | ||||
5 | |||||
6 | inherit native | ||||
7 | |||||
8 | SRC_URI += "file://bjam-native-build-bjam.debug.patch" | ||||
9 | |||||
10 | do_compile() { | ||||
11 | ./bootstrap.sh --with-toolset=gcc | ||||
12 | } | ||||
13 | |||||
14 | do_install() { | ||||
15 | install -d ${D}${bindir}/ | ||||
16 | # install unstripped version for bjam | ||||
17 | install -c -m 755 bjam.debug ${D}${bindir}/bjam | ||||
18 | } |