Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "This is a cross development C compiler, assembler and linker environment for the production of 8086 executables (Optionally MSDOS COM)" |
| 2 | HOMEPAGE = "http://www.acpica.org/" |
| 3 | LICENSE = "Intel-ACPI" |
| 4 | LIC_FILES_CHKSUM = "file://asldefine.h;endline=115;md5=d4d7cf809b8b5e03131327b3f718e8f0" |
| 5 | SECTION = "console/tools" |
| 6 | PR="r1" |
| 7 | |
| 8 | DEPENDS="flex bison" |
| 9 | |
| 10 | SRC_URI="https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz" |
| 11 | |
| 12 | SRC_URI[md5sum] = "324c89e5bb9002e2711e0494290ceacc" |
| 13 | SRC_URI[sha256sum] = "b2b497415f29ddbefe7be8b9429b62c1f1f6e1ec11456928e4e7da86578e5b8d" |
| 14 | |
| 15 | S="${WORKDIR}/acpica-unix-${PV}/source/compiler" |
| 16 | |
| 17 | NATIVE_INSTALL_WORKS = "1" |
| 18 | BBCLASSEXTEND = "native" |
| 19 | |
| 20 | do_compile() { |
| 21 | CFLAGS="-Wno-error=redundant-decls" $MAKE |
| 22 | } |
| 23 | |
| 24 | do_install() { |
| 25 | mkdir -p ${D}${prefix}/bin |
| 26 | cp ${S}/iasl ${D}${prefix}/bin |
| 27 | } |
| 28 | |
| 29 | |