Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Lightweight and flexible command-line JSON processor" |
| 2 | DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \ |
| 3 | filter and map and transform structured data with the same \ |
| 4 | ease that sed, awk, grep and friends let you play with text." |
| 5 | HOMEPAGE = "https://stedolan.github.io/jq/" |
| 6 | BUGTRACKER = "https://github.com/stedolan/jq/issues" |
| 7 | SECTION = "utils" |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=15d03e360fa7399f76d5a4359fc72cbf" |
| 10 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | SRC_URI = "https://github.com/stedolan/${BPN}/releases/download/${BP}/${BP}.tar.gz" |
| 12 | |
| 13 | UPSTREAM_CHECK_URI = "https://github.com/stedolan/${BPN}/releases" |
| 14 | UPSTREAM_CHECK_REGEX = "jq\-(?P<pver>(\d+\.\d+))(?!_\d+).tar.gz" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | |
| 16 | SRC_URI[md5sum] = "e68fbd6a992e36f1ac48c99bbf825d6b" |
| 17 | SRC_URI[sha256sum] = "5de8c8e29aaa3fb9cc6b47bb27299f271354ebb72514e3accadc7d38b5bbaa72" |
| 18 | |
| 19 | inherit autotools-brokensep |
| 20 | |
| 21 | PACKAGECONFIG ?= "oniguruma" |
| 22 | |
| 23 | PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native" |
| 24 | PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native" |
| 25 | PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig" |
| 26 | |
| 27 | OE_EXTRACONF += " \ |
| 28 | --disable-valgrind \ |
| 29 | " |
| 30 | |
| 31 | BBCLASSEXTEND = "native" |