Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Modern password hashing for your software and your servers." |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c" |
| 4 | HOMEPAGE = "https://pypi.org/project/bcrypt/" |
| 5 | |
| 6 | DEPENDS += "${PYTHON_PN}-cffi-native" |
| 7 | |
| 8 | SRC_URI[md5sum] = "fe31390dab603728f756cd3d6830c80a" |
| 9 | SRC_URI[sha256sum] = "5b93c1726e50a93a033c36e5ca7fdcd29a5c7395af50a6892f5d9e7c6cfbfb29" |
| 10 | |
| 11 | inherit pypi python_setuptools_build_meta ptest |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS:${PN}-ptest += " \ |
| 18 | ${PYTHON_PN}-pytest \ |
| 19 | " |
| 20 | |
| 21 | do_install_ptest() { |
| 22 | install -d ${D}${PTEST_PATH}/tests |
| 23 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 24 | } |
| 25 | |
| 26 | RDEPENDS:${PN}:class-target += "\ |
| 27 | ${PYTHON_PN}-cffi \ |
| 28 | ${PYTHON_PN}-ctypes \ |
| 29 | ${PYTHON_PN}-shell \ |
| 30 | ${PYTHON_PN}-six \ |
| 31 | " |