Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | # Copyright (C) 2013 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Library of utility functions from BSD systems" |
| 5 | DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \ |
| 6 | and lacking on others like GNU systems, thus making it easier to port \ |
| 7 | projects with strong BSD origins, without needing to embed the same \ |
| 8 | code over and over again on each project." |
| 9 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | HOMEPAGE = "https://libbsd.freedesktop.org/wiki/" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | # There seems to be more licenses used in the code, I don't think we want to list them all here, complete list: |
| 12 | # OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u |
| 13 | # License: BSD-2-clause |
| 14 | # License: BSD-2-clause-NetBSD |
| 15 | # License: BSD-2-clause-author |
| 16 | # License: BSD-2-clause-verbatim |
| 17 | # License: BSD-3-clause |
| 18 | # License: BSD-3-clause-author |
| 19 | # License: BSD-3-clause-John-Birrell |
| 20 | # License: BSD-3-clause-Regents |
| 21 | # License: BSD-4-clause-Christopher-G-Demetriou |
| 22 | # License: BSD-4-clause-Niels-Provos |
| 23 | # License: BSD-5-clause-Peter-Wemm |
| 24 | # License: Beerware |
| 25 | # License: Expat |
| 26 | # License: ISC |
| 27 | # License: ISC-Original |
| 28 | # License: public-domain |
| 29 | # License: public-domain-Colin-Plumb |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 30 | LICENSE = "BSD-3-Clause & BSD-4-Clause & ISC & PD" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | LICENSE:${PN} = "BSD-3-Clause & ISC & PD" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 32 | LIC_FILES_CHKSUM = "file://COPYING;md5=adf6172075bcc5837e33a8a688eb7e22" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | SECTION = "libs" |
| 34 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 37 | SRC_URI[sha256sum] = "ff95cf8184151dacae4247832f8d4ea8800fa127dbd15033ecfe839f285b42a1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 38 | |
| 39 | inherit autotools pkgconfig |
| 40 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 41 | DEPENDS += "libmd" |
| 42 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 43 | BBCLASSEXTEND = "native nativesdk" |