Brad Bishop | 7cce0f2 | 2017-01-17 09:21:15 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands" |
| 2 | DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands" |
Chris Austen | 9d3325a | 2015-10-24 19:34:11 -0500 | [diff] [blame] | 3 | PR = "r1" |
Patrick Venture | 471c358 | 2018-10-02 19:54:00 -0700 | [diff] [blame^] | 4 | PV = "1.0+git${SRCPV}" |
Chris Austen | 9d3325a | 2015-10-24 19:34:11 -0500 | [diff] [blame] | 5 | |
Matthew Barth | e6d1295 | 2016-09-28 09:51:58 -0500 | [diff] [blame] | 6 | inherit autotools pkgconfig |
Chris Austen | 9d3325a | 2015-10-24 19:34:11 -0500 | [diff] [blame] | 7 | inherit obmc-phosphor-license |
Tom Joseph | dcdc8ea | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 8 | inherit obmc-phosphor-ipmiprovider-symlink |
Tom Joseph | 464b90a | 2017-10-17 22:52:49 +0530 | [diff] [blame] | 9 | inherit pythonnative |
| 10 | |
| 11 | require ${PN}.inc |
Chris Austen | 9d3325a | 2015-10-24 19:34:11 -0500 | [diff] [blame] | 12 | |
Brad Bishop | ceb1c9a | 2017-01-17 10:07:14 -0500 | [diff] [blame] | 13 | DEPENDS += "phosphor-ipmi-host" |
Matthew Barth | e6d1295 | 2016-09-28 09:51:58 -0500 | [diff] [blame] | 14 | DEPENDS += "autoconf-archive-native" |
Patrick Williams | 04f099a | 2017-08-17 10:42:32 -0500 | [diff] [blame] | 15 | DEPENDS += "sdbusplus sdbusplus-native" |
| 16 | DEPENDS += "phosphor-logging" |
| 17 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
| 18 | DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native" |
Tom Joseph | 464b90a | 2017-10-17 22:52:49 +0530 | [diff] [blame] | 19 | DEPENDS += "sdbus++-native" |
Patrick Williams | 04f099a | 2017-08-17 10:42:32 -0500 | [diff] [blame] | 20 | |
| 21 | RDEPENDS_${PN} += " \ |
| 22 | sdbusplus \ |
| 23 | phosphor-logging \ |
| 24 | openpower-dbus-interfaces \ |
| 25 | phosphor-dbus-interfaces \ |
| 26 | " |
Matthew Barth | e6d1295 | 2016-09-28 09:51:58 -0500 | [diff] [blame] | 27 | |
Chris Austen | f6d294d | 2016-01-23 18:00:11 -0600 | [diff] [blame] | 28 | TARGET_CFLAGS += "-fpic" |
Chris Austen | 9d3325a | 2015-10-24 19:34:11 -0500 | [diff] [blame] | 29 | |
Tom Joseph | dcdc8ea | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 30 | HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so" |
| 31 | |
Chris Austen | 9d3325a | 2015-10-24 19:34:11 -0500 | [diff] [blame] | 32 | S = "${WORKDIR}/git" |
| 33 | |
Tom Joseph | dcdc8ea | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 34 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
Matthew Barth | e6d1295 | 2016-09-28 09:51:58 -0500 | [diff] [blame] | 35 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
Tom Joseph | dcdc8ea | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 36 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |