Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | DESCRIPTION="Protocol Buffers with small code size" |
| 2 | LICENSE="Zlib" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9db4b73a55a3994384112efcdb37c01f" |
| 4 | |
| 5 | DEPENDS = "protobuf-native" |
| 6 | |
| 7 | SRC_URI = "git://github.com/nanopb/nanopb.git" |
| 8 | SRCREV = "70f0de9877b1ce12abc0229d5df84db6349fcbfc" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | inherit cmake python3native |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 13 | |
| 14 | do_install_append() { |
| 15 | install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py |
| 16 | install -Dm 0755 ${S}/generator/protoc-gen-nanopb ${D}${bindir}/protoc-gen-nanopb |
| 17 | install -Dm 0755 ${S}/generator/proto/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/proto/__init__.py |
| 18 | } |
| 19 | |
| 20 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
| 21 | FILES_${PN}-dev += "${libdir}/cmake/${BPN}" |
| 22 | |
| 23 | RDEPENDS_${PN} += "\ |
| 24 | ${PYTHON_PN}-protobuf \ |
| 25 | protobuf-compiler \ |
| 26 | " |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 30 | PNBLACKLIST[nanopb] ?= "Needs forward porting to use python3" |