Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 1 | SUMMARY = "Jpeg 2000 implementation" |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://jasper-software.github.io/jasper/" |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a80440d1d8f17d041c71c7271d6e06eb" |
| 5 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 6 | SRC_URI = "git://github.com/jasper-software/jasper.git;protocol=https" |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 7 | SRCREV = "95b2f0583a71c92cddefb54b522efe717b7a5adc" |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit cmake |
| 12 | |
| 13 | PACKAGECONFIG ??= "" |
| 14 | PACKAGECONFIG[jpeg] = "-DJAS_ENABLE_LIBJPEG=true, -DJAS_ENABLE_LIBJPEG=false, jpeg" |
| 15 | PACKAGECONFIG[opengl] = "-DJAS_ENABLE_OPENGL=true, -DJAS_ENABLE_OPENGL=false, freeglut" |
| 16 | |
| 17 | EXTRA_OECMAKE_append = " -DJAS_ENABLE_SHARED=true" |
| 18 | |
| 19 | do_install_append() { |
| 20 | chrpath -d ${D}${bindir}/jasper |
| 21 | chrpath -d ${D}${bindir}/imginfo |
| 22 | chrpath -d ${D}${bindir}/imgcmp |
| 23 | chrpath -d ${D}${libdir}/libjasper.so.* |
| 24 | } |