Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for Linux" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \ |
| 6 | file://build-Allow-CC-and-prefix-to-be-overriden.patch \ |
| 7 | file://no-incdefs-using-host-headers.patch \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI[md5sum] = "d8bb7374943bb747db7786ac26f17f11" |
| 11 | SRC_URI[sha256sum] = "0a24d9401e87d4af023d201e234d91127d82c350daad93432106284aa9459c7d" |
| 12 | |
| 13 | EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \ |
| 14 | EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -DHAVE_ONESTEP_SYNC ${CFLAGS}'" |
| 15 | |
| 16 | do_install () { |
| 17 | install -d ${D}/${bindir} |
| 18 | install -p ${S}/ptp4l ${D}/${bindir} |
| 19 | install -p ${S}/pmc ${D}/${bindir} |
| 20 | install -p ${S}/phc2sys ${D}/${bindir} |
| 21 | install -p ${S}/hwstamp_ctl ${D}/${bindir} |
| 22 | } |