Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "A shell-script tool for converting XML files to various formats" |
| 2 | HOMEPAGE = "https://fedorahosted.org/xmlto/" |
| 3 | SECTION = "docs/xmlto" |
| 4 | LICENSE = "GPLv2" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 7 | |
| 8 | SRC_URI = "https://fedorahosted.org/releases/x/m/xmlto/xmlto-${PV}.tar.gz \ |
| 9 | file://configure.in-drop-the-test-of-xmllint-and-xsltproc.patch \ |
| 10 | file://catalog.xml \ |
| 11 | " |
| 12 | SRC_URI[md5sum] = "0cca8be787ba01e00c618cb390c988b9" |
| 13 | SRC_URI[sha256sum] = "cfd8d2a26077be1d5566dfe22dd66099ae4f4600dea97d6e113a2cc5b8708977" |
| 14 | |
| 15 | inherit autotools |
| 16 | |
| 17 | # xmlto needs getopt/xmllint/xsltproc/bash at runtime |
| 18 | RDEPENDS_${PN} = "docbook-xml-dtd4 \ |
| 19 | docbook-xsl-stylesheets \ |
| 20 | util-linux \ |
| 21 | libxml2 \ |
| 22 | bash \ |
| 23 | " |
| 24 | RDEPENDS_${PN}_append_class-target = " \ |
| 25 | libxslt-bin \ |
| 26 | " |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |
| 29 | |
| 30 | EXTRA_OECONF_append = " XMLLINT=xmllint XSLTPROC=xsltproc" |
| 31 | |
| 32 | do_install_append() { |
| 33 | install -d ${D}${sysconfdir}/xml/ |
| 34 | install -m 755 ${WORKDIR}/catalog.xml ${D}${sysconfdir}/xml/catalog.xml |
| 35 | create_wrapper ${D}/${bindir}/xmlto XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml |
| 36 | } |
| 37 | |
| 38 | do_populate_sysroot[rdeptask] = "do_populate_sysroot" |