Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "libftdi is a library to talk to FTDI chips.\ |
| 2 | FT232BM/245BM, FT2232C/D and FT232/245R using libusb,\ |
| 3 | including the popular bitbang mode." |
| 4 | HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/" |
| 5 | SECTION = "libs" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | LICENSE = "LGPLv2.1 & GPLv2" |
| 7 | LIC_FILES_CHKSUM= "\ |
| 8 | file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \ |
| 9 | file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
| 10 | " |
| 11 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 12 | DEPENDS = "libusb1 python3 swig-native" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | SRC_URI[md5sum] = "0c09fb2bb19a57c839fa6845c6c780a2" |
| 16 | SRC_URI[sha256sum] = "ec36fb49080f834690c24008328a5ef42d3cf584ef4060f3a35aa4681cb31b74" |
| 17 | |
| 18 | S = "${WORKDIR}/${BPN}1-${PV}" |
| 19 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 20 | inherit cmake binconfig pkgconfig python3native |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[cpp-wrapper] = "-DFTDI_BUILD_CPP=on -DFTDIPP=on,-DFTDI_BUILD_CPP=off -DFTDIPP=off,boost" |
| 24 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 25 | EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \ |
| 26 | -DPYTHON_LIBRARY=${STAGING_LIBDIR}/lib${PYTHON_DIR}${PYTHON_ABI}.so \ |
| 27 | -DPYTHON_INCLUDE_DIR=${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 28 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | BBCLASSEXTEND = "native nativesdk" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 30 | |
| 31 | PACKAGES += "${PN}-python" |
| 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | FILES:${PN}-python = "${libdir}/${PYTHON_DIR}/site-packages/" |