Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A privileged helper for utmp/wtmp updates" |
| 2 | DESCRIPTION = "\ |
| 3 | This library provides interface for terminal emulators such as \ |
| 4 | screen and xterm to record user sessions to utmp and wtmp files." |
| 5 | HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter" |
| 6 | SECTION = "System Environment/Libraries" |
| 7 | LICENSE = "GPLv2 & GPLv2+ & LGPLv2 & MIT" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 9 | |
| 10 | SRCREV = "3ef74fff310f09e2601e241b9f042cd39d591018" |
| 11 | PV = "1.1.6-alt2+git${SRCPV}" |
| 12 | |
| 13 | SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 14 | file://0001-Fix-macro-error.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | file://0002-Proper-macro-path-generation.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | file://libutempter-remove-glibc-assumption.patch \ |
| 17 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git/${BPN}" |
| 20 | |
| 21 | CFLAGS += "-DLIBEXECDIR=${libexecdir}" |
| 22 | |
| 23 | do_compile() { |
| 24 | oe_runmake \ |
| 25 | libdir=${libdir} \ |
| 26 | libexecdir=${libexecdir} |
| 27 | } |
| 28 | |
| 29 | do_install() { |
| 30 | oe_runmake install \ |
| 31 | DESTDIR=${D} \ |
| 32 | libdir="${libdir}" \ |
| 33 | libexecdir="${libexecdir}" \ |
| 34 | includedir=${includedir} \ |
| 35 | mandir=${mandir} |
| 36 | |
| 37 | rm -f ${D}${libdir}/*.a |
| 38 | } |
| 39 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | FILES:${PN} = "${libdir}/*.so.*" |
| 41 | FILES:${PN} += "${libexecdir}/utempter/utempter" |
| 42 | FILES:${PN}-dbg += "${libexecdir}/utempter/.debug/utempter" |