Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 1 | SUMMARY = "Perl extension for generating and using LALR parsers" |
| 2 | DESCRIPTION = "Parse::Yapp (Yet Another Perl Parser compiler) is a collection \ |
| 3 | of modules that let you generate and use yacc like thread safe (reentrant) parsers \ |
| 4 | with perl object oriented interface." |
| 5 | |
| 6 | HOMEPAGE = "http://search.cpan.org/dist/Parse-Yapp/" |
| 7 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 9 | |
| 10 | LIC_FILES_CHKSUM = "file://lib/Parse/Yapp.pm;beginline=508;endline=521;md5=41a4542fcde97a600c9de0d782a90256" |
| 11 | |
| 12 | SRC_URI = "https://www.cpan.org/authors/id/W/WB/WBRASWELL/Parse-Yapp-${PV}.tar.gz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "69584d5b0f0304bb2a23cffcd982c5de" |
| 15 | SRC_URI[sha256sum] = "3810e998308fba2e0f4f26043035032b027ce51ce5c8a52a8b8e340ca65f13e5" |
| 16 | |
| 17 | S = "${WORKDIR}/Parse-Yapp-${PV}" |
| 18 | |
| 19 | inherit cpan |
| 20 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 21 | do_install:append() { |
| 22 | sed -i "s:^#!.*:#!/usr/bin/env perl:" ${D}${bindir}/yapp |
| 23 | } |
| 24 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 25 | BBCLASSEXTEND = "native" |