Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 1 | SUMMARY = "Low-Level Interface to bzip2 compression library" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 2 | DESCRIPTION = ""Compress::Raw::Bzip2" provides an interface to the in-memory \ |
| 3 | compression/uncompression functions from the bzip2 compression library." |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Bzip2" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 5 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 6 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 7 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=33084b7f607ba5d38a64b22f8e332f87" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 10 | SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Bzip2-${PV}.tar.gz" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | |
| 12 | SRC_URI[md5sum] = "4fdb7ea5071e4b774c52c37331386355" |
| 13 | SRC_URI[sha256sum] = "a564e7634eca7740c5487d01effe1461e9e51b8909e69b3d8f5be98997958cbe" |
| 14 | |
| 15 | DEPENDS += "bzip2" |
| 16 | |
| 17 | S = "${WORKDIR}/Compress-Raw-Bzip2-${PV}" |
| 18 | |
| 19 | inherit cpan |
| 20 | |
| 21 | export BUILD_BZIP2="0" |
| 22 | export BZIP2_INCLUDE="-I${STAGING_DIR_HOST}${includedir}" |
| 23 | |
| 24 | do_compile() { |
| 25 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 26 | cpan_do_compile |
| 27 | } |
| 28 | |
| 29 | BBCLASSEXTEND = "native" |