Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "A Perl DBI driver for SQLite" |
| 2 | DESCRIPTION = "DBD::SQLite is a Perl DBI driver for SQLite, that includes the entire \ |
| 3 | thing in the distribution. So in order to get a fast transaction capable \ |
| 4 | RDBMS working for your perl project you simply have to install this \ |
| 5 | module, and nothing else. \ |
| 6 | " |
| 7 | HOMEPAGE = "https://metacpan.org/release/DBD-SQLite" |
| 8 | |
| 9 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1726e2117494ba3e13e1c3d93f795360" |
| 12 | |
| 13 | SRC_URI = "${CPAN_MIRROR}/authors/id/I/IS/ISHIGAKI/DBD-SQLite-${PV}.tar.gz \ |
| 14 | file://sqlite-perl-test.pl \ |
| 15 | " |
| 16 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "40fd8ddf539e0e773a7a4e6d376794c3301459f9ab0050978bdcf97113dafe3e" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 18 | |
| 19 | UPSTREAM_CHECK_REGEX = "DBD\-SQLite\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" |
| 20 | |
| 21 | S = "${WORKDIR}/DBD-SQLite-${PV}" |
| 22 | |
| 23 | DEPENDS += "libdbi-perl-native" |
| 24 | |
| 25 | inherit cpan ptest-perl |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | RDEPENDS:${PN} += "libdbi-perl \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 28 | sqlite3 \ |
| 29 | perl-module-constant \ |
| 30 | perl-module-locale \ |
| 31 | perl-module-tie-hash \ |
| 32 | " |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | do_install:append() { |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 35 | if [ ${PERL_DBM_TEST} = "1" ]; then |
| 36 | install -m 755 -D ${WORKDIR}/sqlite-perl-test.pl ${D}/${bindir}/sqlite-perl-test.pl |
| 37 | fi |
| 38 | } |
| 39 | |
| 40 | do_install_ptest() { |
| 41 | cp -r ${B}/MANIFEST ${D}${PTEST_PATH} |
| 42 | chown -R root:root ${D}${PTEST_PATH} |
| 43 | } |
| 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | RDEPENDS:${PN}-ptest += " \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 46 | libtest-nowarnings-perl \ |
| 47 | perl-module-lib \ |
| 48 | perl-module-encode \ |
| 49 | perl-module-file-spec \ |
| 50 | perl-module-file-spec-functions \ |
| 51 | perl-module-findbin \ |
| 52 | perl-module-test-more \ |
| 53 | " |
| 54 | |
| 55 | BBCLASSEXTEND = "native" |