Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "libsecret is a library for storing and retrieving passwords and other secrets" |
| 2 | LICENSE = "LGPLv2.1" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6" |
| 4 | |
| 5 | inherit gnomebase gtk-doc vala gobject-introspection manpages |
| 6 | |
| 7 | DEPENDS += "glib-2.0 libgcrypt gettext-native" |
| 8 | |
| 9 | PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native" |
| 10 | |
| 11 | SRC_URI[archive.md5sum] = "fee403988442f497f3c1dfe7b128869c" |
| 12 | SRC_URI[archive.sha256sum] = "3bfa889d260e0dbabcf5b9967f2aae12edcd2ddc9adc365de7a5cc840c311d15" |
| 13 | |
| 14 | # http://errors.yoctoproject.org/Errors/Details/20228/ |
| 15 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 16 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 17 | ARM_INSTRUCTION_SET_armv6 = "arm" |
| 18 | |
| 19 | # vapigen.m4 bundled with the tarball does not yet have our cross-compilation fixes |
| 20 | do_configure_prepend() { |
| 21 | rm -f ${S}/build/m4/vapigen.m4 |
| 22 | } |