Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "JSON C++ lib used to read and write json file." |
| 2 | DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \ |
| 3 | and writer in C++. JSON (JavaScript Object Notation) is a \ |
| 4 | lightweight data-interchange format. It is easy for humans to \ |
| 5 | read and write. It is easy for machines to parse and generate." |
| 6 | |
| 7 | HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp" |
| 8 | |
| 9 | SECTION = "libs" |
| 10 | |
| 11 | LICENSE = "MIT" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fa2a23dd1dc6c139f35105379d76df2b" |
| 13 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 14 | SRCREV = "d2e6a971f4544c55b8e3b25cf96db266971b778f" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | SRC_URI = "git://github.com/open-source-parsers/jsoncpp" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit cmake |
| 20 | |
| 21 | EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DJSONCPP_WITH_TESTS=OFF" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | |
| 23 | BBCLASSEXTEND = "native" |