Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "The PyPA recommended tool for installing Python packages" |
| 2 | HOMEPAGE = "https://pypi.python.org/pypi/pip" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e" |
| 6 | |
| 7 | DEPENDS += "python3 python3-setuptools-native" |
| 8 | |
| 9 | SRC_URI[md5sum] = "526fd9ec1e6ea956b3571ebfb42cf83c" |
| 10 | SRC_URI[sha256sum] = "f851133f8b58283fa50d8c78675eb88d4ff4cde29b6c41205cd938b06338e0e5" |
| 11 | |
| 12 | inherit pypi distutils3 |
| 13 | |
| 14 | do_install_append() { |
| 15 | # Install as pip3 and leave pip2 as default |
| 16 | rm ${D}/${bindir}/pip |
| 17 | } |
| 18 | |
| 19 | RDEPENDS_${PN} = "\ |
| 20 | python3-compile \ |
| 21 | python3-io \ |
| 22 | python3-html \ |
| 23 | python3-json \ |
| 24 | python3-netserver \ |
| 25 | python3-setuptools \ |
| 26 | python3-unixadmin \ |
| 27 | python3-xmlrpc \ |
| 28 | " |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |