Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame^] | 1 | SUMMARY = "Secure Reliable Transport (SRT) Protocol" |
| 2 | DESCRIPTION = "Secure Reliable Transport (SRT) is an open source transport technology \ |
| 3 | that optimizes streaming performance across unpredictable networks, such as the Internet." |
| 4 | SECTION = "libs" |
| 5 | HOMEPAGE = "https://github.com/Haivision/srt" |
| 6 | LICENSE = "MPL-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad" |
| 8 | |
| 9 | SRCREV = "50b7af06f3a0a456c172b4cb3aceafa8a5cc0036" |
| 10 | SRC_URI = "git://github.com/Haivision/srt;protocol=https \ |
| 11 | file://0001-don-t-install-srt-ffplay.patch \ |
| 12 | " |
| 13 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake pkgconfig |
| 17 | |
| 18 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DENABLE_UNITTESTS=OFF" |
| 19 | |
| 20 | PACKAGECONFIG ??= "crypt" |
| 21 | PACKAGECONFIG[debug] = "-DENABLE_DEBUG=1,," |
| 22 | PACKAGECONFIG[crypt] = "-DENABLE_ENCRYPTION=ON,-DENABLE_ENCRYPTION=OFF,openssl" |
| 23 | PACKAGECONFIG[utils] = "-DENABLE_APPS=ON,-DENABLE_APPS=OFF," |
| 24 | |
| 25 | PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'utils', '${PN}-utils', '', d)}" |
| 26 | FILES_${PN}-utils += "${bindir}" |
| 27 | RDEPENDS_${PN}-utils += "${PN}" |