Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification" |
| 2 | DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \ |
| 3 | middleware consistent with Service Availability Forum (SA Forum) \ |
| 4 | specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \ |
| 5 | established by leading Communications and Enterprise Computing Companies to \ |
| 6 | facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \ |
| 7 | code base in commercial products. \ |
| 8 | The OpenSAF project was launched in mid 2007 and has been under development by \ |
| 9 | an informal group of supporters of the OpenSAF initiative. The OpenSAF \ |
| 10 | Foundation was founded on January 22nd 2008 with Emerson Network Power, \ |
| 11 | Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members." |
| 12 | HOMEPAGE = "http://www.opensaf.org" |
| 13 | SECTION = "admin" |
| 14 | LICENSE = "LGPLv2.1" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7" |
| 16 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | DEPENDS = "libxml2 python3" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 18 | TOOLCHAIN = "gcc" |
| 19 | |
| 20 | SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" |
| 21 | |
| 22 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \ |
| 23 | file://0001-configure-Pass-linker-specific-options-with-Wl.patch \ |
| 24 | file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \ |
| 25 | file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \ |
| 26 | file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \ |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 27 | file://0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 28 | file://0001-immom_python-convert-to-python3.patch \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 29 | file://0001-Fix-build-with-fno-common.patch \ |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame^] | 30 | file://0001-Use-correct-printf-format-for-__fsblkcnt_t.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 31 | " |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame^] | 32 | SRC_URI[md5sum] = "02cfe732d194339237da6adce8e54384" |
| 33 | SRC_URI[sha256sum] = "84268b90dc48a6675e5a77e2b20390a04bb59deb48a829102a9dbc4b9ac27483" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 34 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/opensaf/files/releases" |
| 36 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 37 | inherit autotools useradd systemd pkgconfig |
| 38 | |
| 39 | USERADD_PACKAGES = "${PN}" |
| 40 | GROUPADD_PARAM_${PN} = "-f -r opensaf" |
| 41 | USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf" |
| 42 | |
| 43 | SYSTEMD_SERVICE_${PN} += "opensafd.service" |
| 44 | SYSTEMD_AUTO_ENABLE = "disable" |
| 45 | |
| 46 | PACKAGECONFIG[systemd] = ",,systemd" |
| 47 | PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03,,openhpi" |
| 48 | PACKAGECONFIG[plm] = "--enable-ais-plm,--disable-ais-plm,libvirt openhpi" |
| 49 | |
| 50 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" |
| 51 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 52 | CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation" |
| 53 | CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation=" |
| 54 | LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed" |
| 55 | |
| 56 | do_install_append() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 57 | rm -fr "${D}${localstatedir}/lock" |
| 58 | rm -fr "${D}${localstatedir}/run" |
| 59 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" |
| 60 | rmdir --ignore-fail-on-non-empty "${D}${datadir}/java" |
| 61 | if [ ! -d "${D}${sysconfdir}/init.d" ]; then |
| 62 | install -d ${D}${sysconfdir}/init.d |
| 63 | install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/ |
| 64 | fi |
| 65 | } |
| 66 | |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 67 | FILES_${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service" |
| 68 | FILES_${PN}-dev += "${libdir}/libopensaf_core.so" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 69 | FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a" |
| 70 | |
| 71 | INSANE_SKIP_${PN} = "dev-so" |
| 72 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 73 | RDEPENDS_${PN} += "bash python3-core" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 74 | |
| 75 | # http://errors.yoctoproject.org/Errors/Details/186970/ |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 76 | COMPATIBLE_HOST_libc-musl = 'null' |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 77 | |
| 78 | FILES_SOLIBSDEV = "" |