Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "a fast C/C++ compiler cache" |
| 2 | DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \ |
| 3 | by caching the result of previous compilations and detecting when the \ |
| 4 | same compilation is being done again. Supported languages are C, C\+\+, \ |
| 5 | Objective-C and Objective-C++." |
| 6 | HOMEPAGE = "http://ccache.samba.org" |
| 7 | SECTION = "devel" |
| 8 | |
| 9 | LICENSE = "GPL-3.0-or-later" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=7a19377a02749d8a1281ed608169b0ee" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | |
| 12 | DEPENDS = "zstd" |
| 13 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 14 | SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \ |
| 15 | file://0001-xxhash.h-Fix-build-with-gcc-12.patch \ |
| 16 | " |
| 17 | SRC_URI[sha256sum] = "59b28a57c3a45e48d6049001999c9f94cd4d3e9b0196994bed9a6a7437ffa3bc" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 18 | |
| 19 | UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/" |
| 20 | |
| 21 | inherit cmake |
| 22 | |
| 23 | PATCHTOOL = "patch" |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |
| 26 | |
| 27 | PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc" |
| 28 | PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis" |