Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Lightweight and flexible command-line JSON processor" |
| 2 | DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \ |
| 3 | filter and map and transform structured data with the same \ |
| 4 | ease that sed, awk, grep and friends let you play with text." |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 5 | HOMEPAGE = "https://stedolan.github.io/jq/" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | BUGTRACKER = "https://github.com/stedolan/jq/issues" |
| 7 | SECTION = "utils" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=29dd0c35d7e391bb8d515eacf7592e00" |
| 10 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 11 | SRC_URI = "https://github.com/stedolan/${BPN}/releases/download/${BP}/${BP}.tar.gz \ |
| 12 | file://Support-without-oniguruma.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | " |
| 14 | |
| 15 | SRC_URI[md5sum] = "0933532b086bd8b6a41c1b162b1731f9" |
| 16 | SRC_URI[sha256sum] = "c4d2bfec6436341113419debf479d833692cc5cdab7eb0326b5a4d4fbe9f493c" |
| 17 | |
| 18 | inherit autotools |
| 19 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 20 | PACKAGECONFIG ?= "oniguruma" |
| 21 | |
| 22 | PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native" |
| 23 | PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native" |
| 24 | PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig" |
| 25 | |
| 26 | OE_EXTRACONF += " \ |
| 27 | --disable-valgrind \ |
| 28 | " |
| 29 | |
| 30 | BBCLASSEXTEND = "native" |