blob: 4aca6fee5f0a710c6733556469cbae21407a11d9 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
2HOMEPAGE = "https://github.com/cminyard/gensio"
3LICENSE = "GPL-2.0-only & LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
5 file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
6 "
7
Andrew Geisslerc5535c92023-01-27 16:10:19 -06008SRCREV = "c1e878f5710bafb17aca5ece7d9079e73a78c554"
Andrew Geissler517393d2023-01-13 08:55:19 -06009
10SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=master"
11
12S = "${WORKDIR}/git"
13
14inherit autotools
15
16PACKAGECONFIG ??= "openssl tcp-wrappers"
17
18PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
19PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
20PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
21
22EXTRA_OECONF = "--without-python"
23
24RDEPENDS:${PN} += "bash"