Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design." |
| 2 | SECTION = "libs/network" |
| 3 | HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://${S}/license.txt;md5=a2e15b954769218ff912468eecd6a02f" |
| 6 | DEPENDS = "openssl websocketpp zlib boost brotli" |
| 7 | |
| 8 | EXTRA_OECMAKE = "-DCPPREST_EXPORT_DIR=cmake -DCPPREST_EXCLUDE_BROTLI=OFF" |
| 9 | |
| 10 | SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \ |
| 11 | file://disable-outside-tests.patch \ |
| 12 | file://disable-test-timeouts.patch \ |
| 13 | file://disable-float-tests.patch \ |
| 14 | file://950-fix.patch \ |
| 15 | file://system-brotli.patch \ |
| 16 | " |
| 17 | |
| 18 | # tag 2.10.7 |
| 19 | SRCREV= "c4cef129e880a3f9c23a480e8c983793963173bb" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit cmake |