Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "ISC Kea DHCP Server" |
| 2 | DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS." |
| 3 | HOMEPAGE = "http://kea.isc.org" |
| 4 | SECTION = "connectivity" |
| 5 | LICENSE = "MPL-2.0 & Apache-2.0" |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=0e5b01c848c7736a0c9e68f9c9cd0281" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | |
| 8 | DEPENDS += "kea-native" |
| 9 | |
| 10 | SRC_URI = "\ |
| 11 | http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 12 | file://0001-remove-AC_TRY_RUN.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | file://kea-dhcp4.service \ |
| 14 | file://kea-dhcp6.service \ |
| 15 | file://kea-dhcp-ddns.service \ |
| 16 | " |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 17 | SRC_URI[md5sum] = "c6406ac3d160161056d2fc36557ebd89" |
| 18 | SRC_URI[sha256sum] = "173c8e893690a611bc1d1c6fbe54a5c20fcd54429399a8dc3a0d7d2eb01bf8cc" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
| 20 | inherit autotools systemd |
| 21 | |
| 22 | SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service" |
| 23 | SYSTEMD_AUTO_ENABLE = "disable" |
| 24 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 25 | DEBUG_OPTIMIZATION_remove_mips = " -Og" |
| 26 | DEBUG_OPTIMIZATION_append_mips = " -O" |
| 27 | BUILD_OPTIMIZATION_remove_mips = " -Og" |
| 28 | BUILD_OPTIMIZATION_append_mips = " -O" |
| 29 | |
| 30 | DEBUG_OPTIMIZATION_remove_mipsel = " -Og" |
| 31 | DEBUG_OPTIMIZATION_append_mipsel = " -O" |
| 32 | BUILD_OPTIMIZATION_remove_mipsel = " -Og" |
| 33 | BUILD_OPTIMIZATION_append_mipsel = " -O" |
| 34 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | do_configure_prepend_class-target() { |
| 36 | mkdir -p ${B}/src/lib/log/compiler/ |
| 37 | ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler |
| 38 | } |
| 39 | |
| 40 | do_install_append_class-target() { |
| 41 | install -d ${D}${systemd_system_unitdir} |
| 42 | install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir} |
| 43 | sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 44 | -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 45 | ${D}${systemd_system_unitdir}/kea-dhcp*service |
| 46 | } |
| 47 | |
| 48 | do_install_append() { |
| 49 | rm -rf "${D}${localstatedir}" |
| 50 | } |
| 51 | |
| 52 | PACKAGECONFIG ??= "openssl log4cplus boost" |
| 53 | |
| 54 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl" |
| 55 | PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus" |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame] | 56 | PACKAGECONFIG[boost] = "--with-boost-libs=-lboost_system,,boost,boost" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 57 | |
| 58 | FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a" |
| 59 | FILES_${PN} += "${libdir}/hooks/*.so" |
| 60 | |
| 61 | BBCLASSEXTEND += "native" |
Brad Bishop | 4fe7a13 | 2019-10-07 09:34:48 -0400 | [diff] [blame^] | 62 | |
| 63 | PARALLEL_MAKEINST = "" |