Howard Chiu | 0eb09a1 | 2021-12-09 13:27:04 +0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
| 2 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 3 | |
Potin Lai | 807e2b2 | 2022-04-13 11:24:00 +0800 | [diff] [blame] | 4 | inherit allarch systemd obmc-phosphor-systemd |
Howard Chiu | 0eb09a1 | 2021-12-09 13:27:04 +0800 | [diff] [blame] | 5 | |
| 6 | RDEPENDS:${PN} += "bash" |
| 7 | RDEPENDS:${PN} += "libgpiod-tools" |
Potin Lai | 501f4c7 | 2022-06-13 13:23:57 +0800 | [diff] [blame^] | 8 | RDEPENDS:${PN} += "bletchley-common-functions" |
Howard Chiu | 0eb09a1 | 2021-12-09 13:27:04 +0800 | [diff] [blame] | 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://bletchley-early-sys-init \ |
| 12 | file://bletchley-sys-init.service \ |
| 13 | " |
| 14 | |
| 15 | SYSTEMD_PACKAGES = "${PN}" |
| 16 | SYSTEMD_SERVICE:${PN}:append = " \ |
| 17 | bletchley-sys-init.service \ |
| 18 | " |
| 19 | |
| 20 | do_install() { |
| 21 | install -d ${D}${libexecdir} |
| 22 | install -m 0755 ${WORKDIR}/bletchley-early-sys-init ${D}${libexecdir} |
| 23 | |
| 24 | install -d ${D}${systemd_system_unitdir} |
| 25 | install -m 0644 ${WORKDIR}/bletchley-sys-init.service ${D}${systemd_system_unitdir} |
| 26 | } |
Potin Lai | 807e2b2 | 2022-04-13 11:24:00 +0800 | [diff] [blame] | 27 | |
| 28 | SYSTEMD_OVERRIDE:${PN}:bletchley += "bletchley-sys-init.conf:bletchley-sys-init.service.d/bletchley-sys-init.conf" |