Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 1 | SUMMARY = "GNOME library for reading .desktop files" |
| 2 | SECTION = "x11/gnome" |
| 3 | LICENSE = "GPL-2.0-only & LGPL-2.0-only" |
| 4 | LIC_FILES_CHKSUM = " \ |
| 5 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 6 | file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
| 7 | " |
| 8 | |
| 9 | GNOMEBASEBUILDCLASS = "meson" |
| 10 | |
| 11 | inherit gnomebase itstool pkgconfig upstream-version-is-even gobject-introspection features_check gtk-doc |
| 12 | |
| 13 | REQUIRED_DISTRO_FEATURES = "x11 opengl" |
| 14 | # gobject-introspection is mandatory and cannot be configured |
| 15 | REQUIRED_DISTRO_FEATURES += "gobject-introspection-data" |
| 16 | |
| 17 | GIR_MESON_OPTION = "" |
| 18 | |
| 19 | SRC_URI += "file://gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch" |
| 20 | SRC_URI[archive.sha256sum] = "3d6e153317486157596aa3802f87676414c570738f450a94a041fe8835420a69" |
| 21 | |
| 22 | DEPENDS += " \ |
| 23 | fontconfig \ |
| 24 | gdk-pixbuf \ |
| 25 | glib-2.0 \ |
| 26 | gsettings-desktop-schemas \ |
| 27 | gtk+3 \ |
| 28 | gtk4 \ |
| 29 | iso-codes \ |
| 30 | xext \ |
| 31 | libseccomp \ |
| 32 | libxkbcommon \ |
| 33 | xkeyboard-config \ |
| 34 | xrandr \ |
| 35 | " |
| 36 | |
| 37 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 38 | EXTRA_OEMESON = "-Ddesktop_docs=false" |
| 39 | |
| 40 | PACKAGES =+ "libgnome-desktop" |
| 41 | RDEPENDS:${PN} += "libgnome-desktop" |
| 42 | FILES:libgnome-desktop = " \ |
| 43 | ${libdir}/lib*${SOLIBS} \ |
| 44 | ${datadir}/libgnome-desktop*/pnp.ids \ |
| 45 | ${datadir}/gnome/*xml \ |
| 46 | " |
| 47 | |
| 48 | RRECOMMENDS:libgnome-desktop += "gsettings-desktop-schemas" |