Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 1 | SUMMARY = "library to access web services that claim to be "RESTful"" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/Librest" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 5 | |
| 6 | DEPENDS = " \ |
| 7 | gi-docgen \ |
| 8 | gi-docgen-native \ |
| 9 | glib-2.0 \ |
| 10 | glib-2.0-native \ |
| 11 | json-glib \ |
| 12 | libsoup-2.4 \ |
| 13 | libxml2-native \ |
| 14 | " |
| 15 | |
| 16 | inherit gnomebase gobject-introspection vala pkgconfig |
| 17 | |
| 18 | GNOMEBN = "rest" |
| 19 | |
| 20 | SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9" |
| 21 | |
| 22 | S = "${WORKDIR}/${GNOMEBN}-${PV}" |
| 23 | # * gnome environment requires libsoup build with in gnome PACKAGECONFIG |
| 24 | # * libsoup-gnome support was removed upstream three years ago [1] |
| 25 | # [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720 |
| 26 | EXTRA_OECONF = "--without-gnome" |
| 27 | |
| 28 | do_configure:prepend() { |
| 29 | # rest expects introspection.m4 at custom location (see aclocal.m4). |
| 30 | cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build |
| 31 | } |
| 32 | |
| 33 | do_compile:prepend() { |
| 34 | export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs" |
| 35 | } |