Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Satyr is a collection of low-level algorithms for program \ |
| 2 | failure processing, analysis, and reporting supporting kernel space, user \ |
| 3 | space, Python, and Java programs" |
| 4 | |
| 5 | HOMEPAGE = "https://github.com/abrt/satyr" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 7 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 8 | inherit autotools-brokensep python3native python3targetconfig pkgconfig |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "git://github.com/abrt/satyr.git;branch=master;protocol=https \ |
| 11 | file://0002-fix-compile-failure-against-musl-C-library.patch \ |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 12 | " |
| 13 | SRCREV = "61addf12d15ef9d0bff5e3cc26e08d08a4f88094" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 17 | |
| 18 | DEPENDS += " \ |
| 19 | gdb \ |
| 20 | gperf-native \ |
| 21 | json-c \ |
| 22 | nettle \ |
| 23 | glib-2.0 \ |
| 24 | " |
| 25 | |
| 26 | PACKAGES += "python3-${BPN}" |
| 27 | FILES:python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}" |
| 28 | |
| 29 | PACKAGECONFIG ??= "python3 rpm" |
| 30 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" |
| 31 | PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm" |
| 32 | |
| 33 | do_configure:prepend() { |
| 34 | ${S}/gen-version |
| 35 | } |