Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 1 | DESCRIPTION = "Google Authentication Library" |
| 2 | HOMEPAGE = "https://github.com/googleapis/google-auth-library-python" |
| 3 | AUTHOR = "Google Cloud Platform" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 6 | |
| 7 | inherit pypi setuptools3 |
| 8 | |
| 9 | SRC_URI[sha256sum] = "72f12a6cfc968d754d7bdab369c5c5c16032106e52d32c6dfd8484e4c01a6d1f" |
| 10 | |
| 11 | RDEPENDS:${PN} += "\ |
| 12 | ${PYTHON_PN}-asyncio \ |
| 13 | ${PYTHON_PN}-datetime \ |
| 14 | ${PYTHON_PN}-io \ |
| 15 | ${PYTHON_PN}-json \ |
| 16 | ${PYTHON_PN}-logging \ |
| 17 | ${PYTHON_PN}-netclient \ |
| 18 | ${PYTHON_PN}-numbers \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS:${PN} += "\ |
| 22 | ${PYTHON_PN}-aiohttp \ |
| 23 | ${PYTHON_PN}-cachetools \ |
| 24 | ${PYTHON_PN}-pyasn1-modules \ |
| 25 | ${PYTHON_PN}-rsa \ |
| 26 | ${PYTHON_PN}-six \ |
| 27 | " |