Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 1 | DESCRIPTION = "Google gRPC tools" |
| 2 | HOMEPAGE = "http://www.grpc.io/" |
| 3 | SECTION = "devel/python" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | DEPENDS += "${PYTHON_PN}-grpcio" |
| 11 | |
| 12 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \ |
| 13 | file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \ |
| 14 | " |
| 15 | SRC_URI[sha256sum] = "8e62d23d3fed9d4f81738f98dd193dbd2e21aed4a8f0dd715e75b5439e649727" |
| 16 | |
| 17 | RDEPENDS:${PN} = "${PYTHON_PN}-grpcio" |
| 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |